Számold meg a cellákat, melyek eleget tesznek egy vagy több feltételnek! Erre tudod használni a DARABTELI és a DARABHATÖBB függvényeket.

A feladatban használt fájlt innen letöltheted.

DARABTELI vagy DARABHATÖBB?

A DARABTELI függvény (angolul COUNTIF) megszámolja azokat a cellákat, amelyek eleget tesznek egy feltételnek. A DARABHATÖBB függvény (angolul COUNTIFS) megszámolja azokat a cellákat, amelyek eleget tesznek egy vagy több feltételnek. Elmondható itt is, ami a SZUMHA és ÁTLAGHA függvényeknél is, hogy a DARABHATÖBB függvénynél egyértelműbb az argumentumok elnevezése, de mivel itt nincs összeg-, vagy átlagtartomány, kevésbé lehet elrontani, így használhatod nyugodtan a DARABTELI függvényt is.

DARABTELI függvény

Ebben a bejegyzésben kerül összehasonlításra a két függvény, ha a DARABTELI függvényről szeretnél részletesebb leírást olvasni, nézd meg Excel DARABTELI függvény példákkal című bejegyzésünket!

Darabteli függvény argumentumai: =DARABTELI(tartomány; kritérium)

A példában a budapesti értékesítéseket szeretném megszámolni, a függvény:

=DARABTELI(H4:H23;A14)

darabteli függvény

Az eredmény 11

DARABHATÖBB függvény egy feltétellel

A DARABHATÖBB függvény használható egy feltétellel, ezáltal kiválthatod fele a DARABTELI függvényt.

Argumentumai: DARABHATÖBB(kritériumtartomány1; kritérium1…)

Lényegében ugyanazokat kell megadni, mint a DARABTELI függvénynél.

DARABHATÖBB függvény

Az eredmény ugyanaz.

DARABHATÖBB függvény több feltétellel

Nézzük meg több feltétel esetén is, az egyik példában a budapesti értékesítéseket számolom meg, ahol női kalap került eladásra, majd a második példában a budapesti értékesítéseket, ahol bármilyen kalapot eladtunk 2019. február 15-e előtt.

DARABHATÖBB példa1

Egyszerűen csak adjuk meg a kritériumtartományokat és a hozzájuk tartozó kritériumokat sorban.

=DARABHATÖBB(H4:H23;A15;G4:G23;B15)

Darabhatöbb függvény több feltétellel

Az eredmény 2

DARABHATÖBB példa2

Ugyanez a teendőnk a másik példában is.

Itt láthatod, hogy kicsit más a két kritérium, a *kalap azt jelenti, hogy bármilyen kalap lehet, a kalap előtt bármennyi karakter szerepelhet a cellákban. Maga a * bármennyi karaktert helyettesít, így lehet férfi kalap, vagy női kalap. A dátumoknál, számoknál pedig használhatod a relációjeleket, így az adott dátum előtti napokat úgy adtam meg, hogy <2019.02.15. Ha neked másféle dátumformátumod van, ez Windows beállítás, akkor úgy add meg a dátumot ebben a cellában, ahogy a tálcádon is látod az időpontnál, pl: 15/02/2019

=DARABHATÖBB(H4:H23;A16;G4:G23;B16;F4:F23;C16)

darabhatöbb függvény több feltétel

Az eredmény 4

DARABTELI függvény részletes leírással, rengeteg példával

Bővebb leírást és még több példát megtalálsz Excellence.hu oldalunkon a DARABTELI függvény részletesen, példákkal bejegyzésünkben!